translationStudio Desktop Version 12.1.1

Edit: We’ve released a hotfix, tS version 12.1.1. I’ve updated the links below to refer to the latest build.

Announcement

We are pleased announce the availability of translationStudio Desktop version 12.1.1!

Downloads

tS Desktop Version 12.1.1 Downloads

Note: translationStudio Android is still at version 12.0.

Release Notes

The hotfixes in 12.1.1 were aimed at fixing some installation problems on Windows and Mac. A few other bugs were fixed, you can see the full list at https://github.com/unfoldingWord-dev/ts-desktop/releases/tag/v12.1.1.

Translation Academy in Gateway Languages

We added support for accessing translationAcademy in the Gateway Languages that are published in the Door43 Catalog. Currently this includes English and 5 Gateway Languages (Croatian, Oriya, Hindi, Gujarati, Marathi, see the latest list here).

Included in this feature is the ability to download updates and new translations of unfoldingWord® Translation Academy as they become available.

See the following graphics that illustrate this feature.

Checking for updates:

Downloading tA:

Opening tA from a contextual link:

Opening tA from a contextual link when the translation of tA has not yet been downloaded:

Bugfixes

Export to PDF

There was a bug in the 12.0 release that broke the export to PDF feature, that has been fixed in this release.

Copy and Paste on Mac

The 12.0 release also had a copy and paste bug in the Mac edition that we fixed in this release.

Documentation

The documentation for tS is still at https://ts-info.readthedocs.io/en/latest/index.html.

Uploading to Door43 Issues & Solution

If you are encountering issues uploading to Door43 you will need to logout of your account in translationStudio and log back in. After that you should be able to upload as expected.

You might see any of the following error messages:

09%20PM

or

image%20(5)

or

image%20(6)

If you have seen any of those the solution is to logout and log back in

Background

The underlying issue on the server was resolved as of November 14 at 2:30PM Eastern time. If you had tried logging out and logging back in before that point, it would not have worked. Now, however, performing these steps will fix the problem for you.